Flash Animation: Intermediate level

by: Charina Ong
Centre for Development of Teaching and Learning
National University of Singapore
Table of Contents

About the Workshop........................................................................................................... i
Prerequisites.................................................................................................................... i
Workshop Objectives....................................................................................................... i
Review............................................................................................................................ 1

Working with Symbols ..................................................................................................... 1
  What are Symbols?.......................................................................................................... 1
  Types of Symbols............................................................................................................. 1
Using the Library Panel .................................................................................................... 1
Creating Symbols ............................................................................................................. 2
Working with Instances .................................................................................................. 2

Working with Timelines ................................................................................................. 3
  Frame, Keyframe, Blank Keyframe ................................................................................ 3

Creating Animation........................................................................................................ 4
  Identifying Animations in the Timeline.......................................................................... 4
    Motion Tweening ........................................................................................................... 5
    Classic Tweening .......................................................................................................... 7
      Using Motion Paths.................................................................................................... 7
    Frame by Frame Animation ......................................................................................... 8
    Shape Tweening .......................................................................................................... 9

Adding Interactivity ........................................................................................................ 10
  Importing Sound clip .................................................................................................... 10
  Applying Special Effects ............................................................................................... 10
    Applying Filter Effects ............................................................................................... 10
    Applying the Lightning Effect .................................................................................... 11
  Adding Buttons ............................................................................................................. 12
  Writing Actionscripts .................................................................................................... 13

Self-Assessment............................................................................................................ 15
About the Workshop

Do you have the basics under your belt and want to learn more? This workshop will take you beyond the basics, exploring Flash further in depth. We will focus on creating dynamic elements using Interactivity and basic ActionScripting. By the end of this workshop, you will learn the necessary tools and features to create a low-bandwidth animation.

Prerequisites

In order to fully maximize the benefits of this workshop, participants are expected to have attended the workshop on Flash Beginner’s Level. It would also be an advantage if participants have some basic drawing and computing skills.

Workshop Objectives

By the end of this workshop, participants should be able to:
1. Understand different types of symbols
2. Use Instances
3. Use Flash Library
4. Manage Scenes
5. Animate objects using frame by frame, classic tweening, motion tweening and shape tweening
6. Use motion guide to animate objects
7. Apply special effects to your animation
8. Write basic Actionscripting to control the animation
Review

Working with Symbols

What are Symbols?

You can turn your new artwork into a reusable asset by converting it to a symbol. A symbol is a media asset that can be reused anywhere in your document without the need to re-create it. Symbols can contain images and animations along with other types of content.

When you convert an object to a symbol, Flash automatically creates an instance, which is a copy of a symbol located on the Stage or nested inside another symbol. An instance can be different from its parent symbol in color, size, and function. Editing the symbol updates all of its instances, but applying effects to an instance of a symbol updates only that instance.

It is a good practice to convert all objects to symbol because it can reduce the file size. For example, converting a background image to a graphic symbol allows you to reuse it in other parts of your movie. Symbols can also speed SWF file playback.

Types of Symbols

- **Graphic** - is a reusable static object.
- **Button** - responds to mouse clicks, rollovers, or other actions.
- **Movie clip** - a mini movie or animation within a Flash movie. It has its own Timeline and plays independently of the main movie’s Timeline.

Using the Library Panel

Flash automatically add symbols to the library panel as soon as you create or import them. You can create folders to organize your symbols. Likewise, you can also use the common libraries to access the preset buttons and sounds.
Creating Symbols

Symbols contain all the functionality that Flash creates including animation. Consider creating an animation in a symbol especially if it has a repetitive or cyclic action.

To convert an object to a symbol:
1. Select the object or instance on stage.
2. Click Modify> Convert to Symbol or press F8 key.
3. In the Convert to Symbol dialog box, type in a name for the symbol and then choose either Graphic/Movie clip/Button.
4. Click OK.

To edit a symbol:
1. Double click the object on stage or double click the symbol name from the Library panel.
2. Apply the changes you want.
3. Click Scene 1 to go back to the main timeline.

Activity: Working with Symbols

1. Open 1-symbol.fla. Convert the car a graphic symbol.
2. Select the wheel and convert it to a movie clip symbol.

Working with Instances

Once you have created your symbols, the next step is to bring the instances to your movie.

To add an instance to the stage:
1. Open the Library panel by pressing Ctrl + L.
2. Add a new layer and drag an instance to the stage.
Working with Timelines

Frame, Keyframe, Blank Keyframe

Each time you draw an object on the stage, a black circle appears on the timeline. This black circle is called a **keyframe**. It is indicating that there is an object in that particular frame. It allows you to copy the exact object to another keyframe. Usually this is used when you are animating objects.

Assuming that you want to extend the duration of an object or animation, you can do that by adding a **frame**. You will see a gray area which means Flash will display that object up to a certain number frame.

If you want to introduce a new object without affecting the previous objects displayed on the timeline, you can use a blank keyframe.

**Tip:**
- Press **F5** to add a frame (extend the duration of an object on stage)
- Press **F6** to add a keyframe (duplicate the object)
- Press **F7** to add a blank keyframe (introduce a new object)
Creating Animation

Flash provides several ways to create animation and special effects. Each method provides you with different possibilities for creating engaging animated content.

- **Motion tween** - creates animation that is continuously looping.
- **Shape tween** - changes one shape to another, in a process known as morphing.
- **Frame-by-frame animation** - Flash animates an object gradually over several consecutive frames. You can control the action in every frame, which may be necessary in a complex animation.

Identifying Animations in the Timeline

Flash distinguishes tweened animation from frame-by-frame animation in the Timeline by displaying different indicators in each frame that contains content.

- A span of frames with a blue background indicates a motion tween. A black dot in the first frame of the span indicates that the tween span has a target object assigned to it. The black diamond indicates the last frame and any other property keyframe.

```
••••
```

- A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween span still contains its property keyframe and can have a new target object applied to it.

```
••••
```

- A black dot at the beginning keyframe with a black arrow and g background indicates a classic tween.

```
•→
```

- A dashed line indicates that the classic tween is broken or incomplete, such as when the final keyframe is missing.

```
•-•-•-•-•-•-•
```
• A black dot at the beginning keyframe with a black arrow and a light green background indicates a shape tween.

• A black dot indicates a single keyframe. Light gray frames after a single keyframe contain the same content with no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the span.

• A small a indicates that the frame is assigned a frame action with the Actions panel.

Activity: Motion Tweening
1. Save a copy of 1-symbol.fla and name it as 2a-motion-tween.fla.
2. Animate the car by moving from left to right of the stage.
3. Animate the wheel movie clip so auto-rotate it as the car moves.

Motion Tweening
Now that you learn the basic of motion tweening, you can explore other techniques to allow you to work faster as you animate your objects.

Flash allows you to copy the animation you have applied from one object and paste it to another object in the timeline.

To copy a motion path:
1. Open 2b-motion-tween.fla.
2. Insert a new layer and name it as biker 2.
3. In this layer, click on frame 1 and then drag the g_biker symbol from the Library panel to the stage.
4. Right click on any frame on the tween span on the biker layer, and choose Copy Motion.
5. Right click on the new instance (biker2) and then choose Paste Motion.
6. Hide biker layer.
7. Using the Free Transform Tool, select the motion path on stage.
8. Click **Modify > Transform > Flip Horizontal**.
9. Use the arrow keys to align the biker to the path.

10. Select the biker instance on stage and then click **Modify > Transform > Flip Horizontal** to make sure that the biker is facing the right direction.
11. Save your work and preview the animation by pressing **CTRL + ENTER** keys.

To rotate the object:
1. Notice that the biker is facing downwards as you play the animation.
2. Select the biker instance on stage and use the **Free Transform** tool to rotate it upward.
3. In the **Properties** Inspector, click the **Orient to path** option to make the animation more realistic.

4. Move the animation of the biker 2 to frame 40.
5. Extend the duration of the ramps and buses layers until frame 80.
6. Save your work and preview the animation by pressing **CTRL + ENTER** keys.
Classic Tweening

Using Motion Paths

The motion path is a line that represents the spatial movement of the tweened instance, and it has dots that represent the target objects position along the path at frames on the timeline. Each segment of the motion path is editable.

To apply motion path to an object:
1. Open 3-classic-tween.fla.
2. Insert a new layer and name it as biker.
3. Click Frame 1 on the biker layer and then drag g_biker symbol from the Library panel.
4. Add a keyframe in frame 30 by pressing F6 key.
5. Drag the biker to the opposite side of the stage.
6. Right click on the Timeline and choose Create Classic Tween. Notice that the biker moves from left to right. We will add in a motion path to add a nice effect.
7. Right click on the biker layer and choose Add a Classic Motion Guide. This will create an additional layer on top of the biker layer. You can use this invisible layer to draw the path for your animation.
8. Click Frame 1 on the Guide layer.
9. Using the Pencil tool, draw a path similar to this:

![Path drawing](image)

10. Rotate the biker so that it is facing upward.
11. Using the Free Transform Tool, click the biker instance on stage and make sure that the registration point is connected to the starting and ending point of the path you created.

![Registration point](image)

12. Save your work and preview the animation by pressing CTRL + ENTER keys.
Frame by Frame Animation

Frame-by-frame animation is the closest to the traditional animation techniques where content is created in every frame. Although it is time consuming compared to tweening, it provides the designer full control over the animation.

Please take note that a frame-by-frame animation can increase the file size more rapidly than a tweened animation.

To create frame by frame animation:
1. Open 4-frame-by-frame.fla.
2. Insert a new layer and name it as stickfig.
3. Click Frame 5 on the stickfig layer and press down F6 key to create a keyframe.
4. Drag stickfig1 from the Library panel to the left edge of the stage.
5. Click Frame 6 on the stickfig layer and insert a blank keyframe by pressing F7 key.
6. Click the Edit multiple frames button from the Timeline. This allows you to view the content of more than one frame at a time.
7. Drag stickfig2 to the right side of stickfig1.
8. Click Frame 7 on the stickfig layer and insert a blank keyframe by pressing F7 key.
9. Drag stickfig3 to the right side of stickfig2.
10. Click Frame 8 on the stickfig layer and insert a blank keyframe by pressing F7 key.
11. Drag stickfig1 to the right side of stickfig3.
12. Click Frame 9 and insert a blank keyframe by pressing F7 key.
13. Drag stickfig2 to the right side of stickfig1.
14. Click Frame 10 and insert a blank keyframe by pressing F7 key.
15. Drag stickfig3 to the right side of stickfig2.
16. Click Frame 11 and insert a blank keyframe by pressing F7 key.
17. Click the Edit multiple frames button from the Timeline to turn it off.
18. Change the movie frame to 6fps.
19. Save your work and preview the animation by pressing CTRL + ENTER keys.

Shape Tweening
Shape tweening allows you to draw a shape at one frame, and then you change that shape or draw another shape at another frame, creating a morphing effect.

To create shape tweening:

1. Create a new file and name it as 5-shape-tween.fla.
2. Click Frame 1 and draw a rectangular shape from the Tool panel.
3. Click Frame 24 and press F7 key to insert a blank keyframe.
4. Draw a circular shape.
5. Copy the object from frame 1 and paste it in frame 48.
6. Right click on the Timeline and select Create shape tween.
7. Save your work and preview the animation by pressing CTRL + ENTER keys.
Adding Interactivity

Importing Sound clip

Flash allows you to import multimedia files such as audio and video to enhance your animation. All the elements are stored in the Library folder which can be reused at anytime.

To import a sound clip:
1. Open the file halloween_ecard.fla.
2. Insert a new layer in the Timeline and name it as sound effect.
3. Click File>Import>Import to Library.
4. Locate sound effect.mp3 from the Flash intermediate folder on your desktop, and click Open.
5. Open the Library panel, and drag the sound clip to the Stage.
6. In the Sound panel, select Stream in theSynch option.
7. Save your work and preview the animation by pressingCTRL + ENTER keys.

Applying Special Effects

Flash CS6 has several tools to apply special effects to your animation. This includes the use of filters and the Decorative drawing tools.

Filter Effects can be applied to movie clip and symbol instances to create blurs, glows, drop shadows, and other effects.

The decorative drawing tools let you turn graphic shapes that you create into complex, geometric patterns, which can be applied to a movie clip or graphic symbol. You can choose from a range of effects from the Property Inspector and apply it to a selected object on stage.

Applying Filter Effects

To apply a glow effect:
1. Select the moon layer in the Timeline.
2. Right click the moon on stage and select Create motion tween.
3. With the moon still selected, click Add Filter button at the bottom of the Filters section of the Property Inspector. Choose Glow from the list. Select white for the colour and set the Blur X and Blur Y to 100.
4. Click on frame 60 and change the **Strength** option of the glow effect to **250**.
5. Click on frame 120 and change the **Strength** option back to **100**. This creates a loop where the glow gets more intense between frames 1 and 60 and then return to its original strength when it reaches frame 120.
6. Save your work and preview the animation by pressing **CTRL + ENTER** keys.

**Applying the Lightning Effect**

The lightning brush effect lets you create lightning bolts. You can also use this to create an animated lightning.

To apply lightning effect:
1. Insert a new layer in the Timeline and name it as **lightning**.
2. Click the Deco tool in the Tools panel.
3. Select the **Lightning brush** effect from the Drawing effect menu in the Properties Inspector.
4. Set the Properties for the Lightning Brush effect.
   - Lightning colour- the colour of the lightning
   - Lightning scale- the length of the lightning
   - Animation- allows you to create frame by frame animation of the lightning. Flash adds frames to the current layer in the Timeline while the lightning is being drawn
   - Beam width- the thickness of the lightning at its root
   - Complexity- the number of times each branch divides. Higher values create longer lightning with more branches.
5. Drag the object on stage. Flash draws lightning toward the direction you move the mouse. Notice that as the lightning creates branches with a random appearance each time, you may need to redraw the lightning to achieve the desire effect.
6. Press **F7** key to insert a blank keyframe and then create another lightning effect.
7. Save your work and preview the animation by pressing **CTRL + ENTER** keys.
Adding Buttons

Buttons are symbols that contain four frames. Each frame of a button symbol represents a different state for the button: Up, Over, Down, and Hit. These states determine how a button visually behaves when the mouse is rolled over it or when the user clicks the button. You add a button into your movie by using the pre-built buttons in the Common Libraries or design your own button that will match the movie that you are creating.

To add a button:
1. Open halloween_eacrd.fla.
2. Insert a new layer and name it as buttons.
3. Click Window > Common Libraries > Buttons.
4. Choose a button that you like and drag it to the stage.
5. Click on the red button and provide an instance name in the Properties Inspector. Type stopBtn.
6. Click on the green button and provide an instance name in the Properties Inspector. Type playBtn.
7. Save your work by pressing CTRL + S.

To create your own button:
1. Use the drawing tool in the Tools panel to design your button.
2. Press F8 key to convert it to a symbol.
3. Provide a name such as stopBtn and select Button in the Type option.
4. Double click on the button symbol to edit the up, over, down and hit states. Please make sure that the entire button is clickable in the Hit state.
5. Click on Scene 1 to go back to the main timeline.
6. Click on the stop button on stage and provide an instance name in the Properties Inspector such as stopBtn.

7. To duplicate the button you have created, open the Library panel by pressing CTRL + L.
8. Right click on stopBtn and select Duplicate.
9. Name the new button as playBtn and then click OK.
10. Drag the playBtn symbol on stage.
11. Double click on the playBtn symbol to make the changes.

12. Enter an instance name for the play button. Name is as playBtn.
13. Save your work and preview the animation by pressing CTRL + ENTER keys.
Notice the changes happen when you point your mouse to the button. No action will be generated because we have not placed in the code yet to the buttons.

**Writing Actionscripts**

ActionScript is an object-oriented programming language that is designed specifically for Web site animation. The stop command is most likely the most basic of all action script commands, and the most essential. A stop is basically an instruction in the ActionScript program language that tells your Flash movie to pause on a particular frame, rather than continuing to the end of the animation or cycling endlessly. Stop commands are particularly useful if you are playing an animation before pausing to wait for a user response. While ActionScripting is a programming language, Flash's library allows you to write in the language without actually typing the code yourself.
To stop the animation:
1. Insert a new layer in the Timeline and name it as **actions**.
2. Click on the stop button on stage and press **F9** key to open the Actions panel.
3. Click the **Code Snippet** button and then choose **Event handlers** > **Mouse Click Event**.
4. Use the code below:

   ![Code Snippet for stopping animation]

   To resume the animation:
1. Click on the play button on stage and press **F9** key to open the Actions panel.
2. Click the **Code Snippet** button and then choose **Event handlers** > **Mouse Click Event**.
3. Click the **Code Snippet** button and then choose **Event handlers** > **Mouse Click Event**. Notice that the code for the stop button will be displayed. We will add-in the code to continue playing the animation when the user clicks Play.
4. Save your work and preview the animation by pressing **CTRL + ENTER** keys.

To link it to a website:
1. Provide an instance name to the button you have created. For example, **urlBtn**.
2. Click the button on stage and press **F9** key to open the Actions panel.
3. Click the **Code Snippet** button and then choose **Actions** > **Click to go to a webpage**.
4. Enter the URL in the code.
Self-Assessment

1. Open `hula-girl.fla` and animate the dance movement that you want. Apply the different animation techniques you learned (motion tween, classic tween, shape tween and frame by frame)
2. Add background music and sync it with your animation.
3. Add stop and play buttons to control the animation.

Example: